B&O Sound System issues anyone? Speakers sound blown out sometimes

Stu H

Member
First Name
Stu
Joined
Jan 14, 2022
Threads
1
Messages
9
Reaction score
1
Location
Vacaville
Vehicles
2021 Mach E GT PE
Anyone else having an issue with the B-O Sound System in the MME GT-PE?

Mine sounds so tinny it is almost undecipherable for Nav system as well as satellite radio and bluetooth from phone reception. Sounds like all speakers are blown out (which is not the case) but the hands free phone clarity is fine.

Sounds like a claim is coming from me.

GT T UP

 

breeves002

Well-Known Member
First Name
Sam
Joined
Feb 21, 2021
Threads
90
Messages
1,649
Reaction score
3,346
Location
St. Louis, MO
Vehicles
2021 Mach-E GT PE
Country flag
Video? Sounds broken.
 
OP
OP

Stu H

Member
First Name
Stu
Joined
Jan 14, 2022
Threads
1
Messages
9
Reaction score
1
Location
Vacaville
Vehicles
2021 Mach E GT PE
Dunno where the video ads came from...not me. I'm referring strictly to the audio quality, which was good for the first 17,000 miles then when to 'bees in a can' quality.

GT T UP!
 

Mauser

Well-Known Member
Joined
Jul 15, 2022
Threads
12
Messages
115
Reaction score
70
Location
Canada
Vehicles
'22 Mach-e GT-PE Space White
Have you tried rebooting the console? Maybe a driver/amp issue as opposed to a speaker problem?
 

GuliblGuy

Well-Known Member
First Name
Justin
Joined
Apr 8, 2021
Threads
12
Messages
467
Reaction score
796
Location
North Tustin, CA
Vehicles
Shadow Black 2021 Premium 4X Mach E
Country flag
Dunno where the video ads came from...not me. I'm referring strictly to the audio quality, which was good for the first 17,000 miles then when to 'bees in a can' quality.

GT T UP!
He's asking for a video of your problem so we can hear it and try and diagnose a problem...
 


2FlyMache

Well-Known Member
First Name
Patrick
Joined
Aug 9, 2021
Threads
4
Messages
425
Reaction score
374
Location
Martinez GA
Vehicles
2021 Rapid Red Ex4 MachE
Country flag
I've noticed a couple of times my CarPlay doesn't flip to stereo and when I adjust volume it shows voice volume instead of volume. It sound mono vs stereo.
 

Mach-Lee

Well-Known Member
First Name
Lee
Joined
Jul 16, 2021
Threads
96
Messages
3,675
Reaction score
6,167
Location
Wisconsin
Vehicles
2022 Mach-E Premium AWD
Occupation
Sci/Eng
Country flag
Anyone else having an issue with the B-O Sound System in the MME GT-PE?

Mine sounds so tinny it is almost undecipherable for Nav system as well as satellite radio and bluetooth from phone reception. Sounds like all speakers are blown out (which is not the case) but the hands free phone clarity is fine.

Sounds like a claim is coming from me.

GT T UP
Reset the DSP module with FORScan or lift the negative battery cable.
 

ripperAZ

Well-Known Member
First Name
Ripper
Joined
Mar 4, 2022
Threads
17
Messages
721
Reaction score
936
Location
AZ DESERT
Vehicles
2022 Ice White Mustang Mach E AWD EX BATT
Reset the DSP module with FORScan or lift the negative battery cable.
Indeed. I’ve had the tinny volume and I think it’s broadcasting only in voice mode. As MachLee says a battery negative reset pull worked for me. May save a fruitless dealer experience for a gamey bug that is only fixed by a reboot.

Jes sayin
 
OP
OP

Stu H

Member
First Name
Stu
Joined
Jan 14, 2022
Threads
1
Messages
9
Reaction score
1
Location
Vacaville
Vehicles
2021 Mach E GT PE
I'll try it!

GT T UP
 
OP
OP

Stu H

Member
First Name
Stu
Joined
Jan 14, 2022
Threads
1
Messages
9
Reaction score
1
Location
Vacaville
Vehicles
2021 Mach E GT PE
OK. Took the car in to the shop last week for 20k service and a look/listen to the B&O system issue.

The diagnosis was a bad speaker, and then a further check.

They still have the car, but have furnished me a loaner (2022 Convert Mustang) so I've had the top down since I got it).

I must say that I did offer to trade the car in for a straight across swap, as is, where is for another car that was at the dealership for a slight (my estimate was about $2k worth) damage repair.

Unfortunately for me, that didn't happen, so I keep the MME PE.

Oh yeah, the other car was a 2006 Ford GT (like the GT 40).

Well, you cant blame me for trying.....
 

TheSeg

Well-Known Member
First Name
Seg
Joined
Oct 5, 2020
Threads
8
Messages
234
Reaction score
559
Location
San Francisco Bay Area, CA
Website
seg.fyi
Vehicles
2021 Mach-E Premium EB-RWD (Built: Feb 2021)
Country flag
I've been working with Ford support and my dealership with this problem. The center-front speaker's blown out as if the microphone gain is set too high. The video below shows me adjusting the balance to illustrate the problem front-center speaker, center-back speaker (working), and then true center.


At this time I have my car, but Wallnut Creek Ford has ordered a new center front speaker to replace and my appointment is set for Oct 1st. I'm very thankful they let me have the car while they wait for parts, rather than having an otherwise working car sitting in their lot.
 

Rakka

Member
First Name
Gurprit
Joined
Oct 18, 2021
Threads
0
Messages
21
Reaction score
25
Location
Elk Grove CA
Vehicles
Mustang GT, Mach E Premium, Explorer
Occupation
IT
Country flag
I am experiencing the exact same issue as the video posted by TheSeg. Took it to the dealer today and they said they could not duplicate the issue. I could hear the issue but they said they could not. Then realized I should have asked them try the built in navigation. Sure enough they confirmed it’s an issue. They ordered a new center speaker and will be delivered on 9/27. Have appointment at 9am to have it installed on that day. Will share my results.

17k miles on the car. 2021 Job 2. Great car.
 

Mach-Lee

Well-Known Member
First Name
Lee
Joined
Jul 16, 2021
Threads
96
Messages
3,675
Reaction score
6,167
Location
Wisconsin
Vehicles
2022 Mach-E Premium AWD
Occupation
Sci/Eng
Country flag
I've been working with Ford support and my dealership with this problem. The center-front speaker's blown out as if the microphone gain is set too high. The video below shows me adjusting the balance to illustrate the problem front-center speaker, center-back speaker (working), and then true center.


At this time I have my car, but Wallnut Creek Ford has ordered a new center front speaker to replace and my appointment is set for Oct 1st. I'm very thankful they let me have the car while they wait for parts, rather than having an otherwise working car sitting in their lot.
What volume level do you have that set at? 7-8 should be a normal listening volume. If that sounds quiet then you need to pull the battery cable to reset the DSP module.
 

TheSeg

Well-Known Member
First Name
Seg
Joined
Oct 5, 2020
Threads
8
Messages
234
Reaction score
559
Location
San Francisco Bay Area, CA
Website
seg.fyi
Vehicles
2021 Mach-E Premium EB-RWD (Built: Feb 2021)
Country flag
What volume level do you have that set at? 7-8 should be a normal listening volume. If that sounds quiet then you need to pull the battery cable to reset the DSP module.
I have it turned up to 12-14 these days as all the sound is coming from the back, but as I said they will be replacing the part on Oct 1st. The only reason it's not sooner are scheduling conflicts on my end.
 

Mach-Lee

Well-Known Member
First Name
Lee
Joined
Jul 16, 2021
Threads
96
Messages
3,675
Reaction score
6,167
Location
Wisconsin
Vehicles
2022 Mach-E Premium AWD
Occupation
Sci/Eng
Country flag
I have it turned up to 12-14 these days as all the sound is coming from the back, but as I said they will be replacing the part on Oct 1st. The only reason it's not sooner are scheduling conflicts on my end.
What I'm saying is the part could be fine, the amplifier probably just needs a reset due to a software glitch. You might not have to go to the dealer.

At volume level 13 I get about 78 dB between the front seats with the fader centered, and 70 dB with the fader full rear. If only the front center speaker is bad, you'll still be getting plenty of sound from the front door speakers. Your low volume symptoms are more characteristic of the DSP needing to be reset rather than a center speaker failure. The DSP glitch does cause clipping which sounds like a bad speaker but it's the amplifier doing it.

 

 
Top