Comprehensive PowerUp (OTA) Poll (1.x-2.x)

What is your Mach E's current PowerUp level?


  • Total voters
    496

Chainspell

Well-Known Member
First Name
Erich
Joined
Aug 7, 2021
Threads
5
Messages
95
Reaction score
71
Location
Sacramento, CA
Vehicles
'21 Premium 4X, '23 GTPE (on order)
Country flag
Got 2.8.1 on Thursday. Nothing over the weekend, but just a 10 second backup drive out of the garage into the driveway was enough to trigger 2.8.2 today! Bluecruise tested and working. Finally!

 

mrgoofy45

New Member
First Name
Wayne
Joined
Feb 27, 2021
Threads
0
Messages
4
Reaction score
7
Location
94509
Vehicles
Chevy Volt, Nissan Muano
Occupation
Healthcare Worker
Country flag
The dealership failed, for a week, trying to do Blue Cruise upgrade. Ford finally told the dealership to give me back the car, and they'd try to force it OTA. It didn't upgrade any over the next few days, until I noticed I had no schedule hours for upgrades. Once I told it to update every night from 9pm to 6am, the upgrades came fast. Within a few days I had Blue Cruise and it says latest upgrade is 2.83.
 

OH2AZ2OH

Well-Known Member
Joined
Jan 11, 2021
Threads
6
Messages
480
Reaction score
629
Location
Dublin, OH
Vehicles
Mach E 4X
Country flag
Got 2.8.1 on Thursday. Nothing over the weekend, but just a 10 second backup drive out of the garage into the driveway was enough to trigger 2.8.2 today! Bluecruise tested and working. Finally!
Did your first start after 2.8.2 behave really strange? I don’t remember the details now, but the car definitely did not start for me, and I had a progress bar on the center console with a strange message that I don’t recall. After 30 seconds or so, well before the progress bar finished, CarPlay connected, and then it started normally. I assumed it was related to the update, but LVB/HVBJB failure was definitely in the back of my mind.
 

Mathington

Well-Known Member
Joined
Jul 6, 2021
Threads
18
Messages
791
Reaction score
758
Location
Canada
Vehicles
Mach-E Premium SR AWD
Country flag
Just updated my vote to 2.5.2 after I received 2.8.2 last night and have BlueCruise and used it on my commute.
 

Chainspell

Well-Known Member
First Name
Erich
Joined
Aug 7, 2021
Threads
5
Messages
95
Reaction score
71
Location
Sacramento, CA
Vehicles
'21 Premium 4X, '23 GTPE (on order)
Country flag
Did your first start after 2.8.2 behave really strange? I don’t remember the details now, but the car definitely did not start for me, and I had a progress bar on the center console with a strange message that I don’t recall. After 30 seconds or so, well before the progress bar finished, CarPlay connected, and then it started normally. I assumed it was related to the update, but LVB/HVBJB failure was definitely in the back of my mind.
Yes, but it was more of a SYNC issue. I didn't see what you described. My climate control power buttons were swapped. It was really bizarre. I.E. when it was "on" the fans would turn off. Then when it was set to "off" it would turn back on, presumably at my last temp setting. All that cleared away after restart.
 


iam-s-Hon

Well-Known Member
First Name
Richard
Joined
May 20, 2021
Threads
2
Messages
199
Reaction score
189
Location
Maryland
Vehicles
2021 Job 1 MME Premium AWD ER Iconic Silver
Country flag
After sitting on 2.6 for a few weeks (just before Memorial Day weekend) the 2.7s started rolling in.
.1 (6/15), .3 (6/18) and .4 (6/21). No issues...

Hoping for a not-too long wait for BC in order to give it a try.
 

Mathington

Well-Known Member
Joined
Jul 6, 2021
Threads
18
Messages
791
Reaction score
758
Location
Canada
Vehicles
Mach-E Premium SR AWD
Country flag
Updated my vote to 2.8.3
 

BMT1071

Well-Known Member
First Name
Mike
Joined
Mar 21, 2021
Threads
55
Messages
2,543
Reaction score
3,466
Location
Glendale, AZ
Vehicles
21 Infiniti QX50, 21 MME SR RWD
Occupation
Regional Service Manager
Country flag
2.7.1 showed up today, so I changed my vote to 2.4.1
 

jetermeyer

Well-Known Member
First Name
Jeff
Joined
Oct 25, 2020
Threads
1
Messages
85
Reaction score
75
Location
MA
Vehicles
Lexus NX 300H, Acura TLX
Occupation
Retired
Country flag
I was stuck on 1.7.1 for 6 months. Finally got that fixed at dealer and within a couple of weeks I received a bunch of updates all the way to 2.8.3. Blue Cruise activated. Just went to check for updates and noticed my auto update will not stay on. Same as before 1.7.1. I'm able to turn it on but as soon as I leave the screen it reverts to off. Anyone else seeing this problem? 10 steps forward now 1 back:(
 

reirey

Member
First Name
Reina
Joined
Sep 8, 2021
Threads
1
Messages
16
Reaction score
10
Location
San Francisco
Vehicles
2021 Mustang Mach-E
Country flag
I got 2.7.4 about a week ago. Is there an official list of updates from Ford? Would be nice to look at a list of updates and see what's coming up for me.
 

BMT1071

Well-Known Member
First Name
Mike
Joined
Mar 21, 2021
Threads
55
Messages
2,543
Reaction score
3,466
Location
Glendale, AZ
Vehicles
21 Infiniti QX50, 21 MME SR RWD
Occupation
Regional Service Manager
Country flag

DRuth086

Well-Known Member
First Name
Daniel
Joined
Oct 1, 2021
Threads
11
Messages
135
Reaction score
107
Location
East Providence, RI
Vehicles
Black 2021 Mach-E AWD Extended Range
Occupation
Graphic Designer
Country flag
My car tried 2.7.3 last night. It failed. Surprised by this as I've had BlueCruise since my dealer installed it over months ago.

 

 
Top