Customer Support Help with Activation

Mojuba

Active Member
First Name
Chris
Joined
Jan 28, 2020
Messages
27
Reaction score
29
Location
Huntington Beach
Vehicles
Reserved Mach E First Edition
Country flag
Okay, so I've spent 2 hours this morning trying to get help with Ford Support. I was provided a case number and was finally transferred to a specialist. As the call began with the "specialist" I was disconnected and given the satisfaction survey.

I'm now trying to get back to a specialist and even though I have a case number, I have to go through the same rigmarole. Does anyone have any direct contacts so I don't have to wait another 2 hours and possibly be disconnected. As I'm typing I just had my FOURTH disconnect this morning and my 4th satisfaction survey with 1s on support. I'm FURIOUS

Having issues where my profile is not being sent to my vehicle amongst other nits here and there (at one point it said my vehicle wasn't allowed to submit external data, even though it was). My vehicle is in my driveway in an area with very good coverage.

Does anyone have direct contact or a way I can get back to a specialist? I have a case number but that seems to do nothing.

Thanks!!
Advertisement

 

tblevins

New Member
First Name
Todd
Joined
Aug 26, 2020
Messages
1
Reaction score
0
Location
TN
Vehicles
Mach e
Country flag
Same issue here. I tried the FordPass Guide chat and it was useless. Was on the chat for an hour and never got a solution from the rep.
 
OP
OP

Mojuba

Active Member
First Name
Chris
Joined
Jan 28, 2020
Messages
27
Reaction score
29
Location
Huntington Beach
Vehicles
Reserved Mach E First Edition
Country flag
OMG, my 6th phone call, and I can't get back to the specialist I had before. I keep working with first-line people. I get to the in-vehicle support team and the last person transferred me to marketing, and then said that I need to be in the in-vehicle team, but still can't seem to get to a specialist.

The person who transferred me to the marketing team, let me know that it had to do with my in-vehicle hot spot, which was why marketing was supposed to help me out. Perhaps, the person who declined the vehicle that I picked up registered for the hotspot? Since my hot-spot is showing as active and someone set up a personalized SSID. Have other vehicles had a hotspot already set up when you got in your vehicle?

Marketing transferred me back to In-vehicle support and got disconnected again. On 4 hours of support today.
 

JellyBelly

Well-Known Member
First Name
Kris
Joined
Jun 27, 2020
Messages
2,305
Reaction score
1,816
Location
San Diego
Vehicles
MME RR FE
Country flag
OMG, my 6th phone call, and I can't get back to the specialist I had before. I keep working with first-line people. I get to the in-vehicle support team and the last person transferred me to marketing, and then said that I need to be in the in-vehicle team, but still can't seem to get to a specialist.

The person who transferred me to the marketing team, let me know that it had to do with my in-vehicle hot spot, which was why marketing was supposed to help me out. Perhaps, the person who declined the vehicle that I picked up registered for the hotspot? Since my hot-spot is showing as active and someone set up a personalized SSID. Have other vehicles had a hotspot already set up when you got in your vehicle?

Marketing transferred me back to In-vehicle support and got disconnected again. On 4 hours of support today.
That must be frustrating to say the least - Ford needs to improve the help process for this tech stuff. I am not sure if it helps but have you contacted the dealer? I am not sure we have heard of a hotspot being already active before.
 

benk016

Well-Known Member
First Name
Ben
Joined
Nov 12, 2020
Messages
1,535
Reaction score
2,315
Location
Tulsa, Oklahoma
Vehicles
2021 Mustang Mach-E GT
Country flag
How long ago did you take delivery? I wasn't able to push my profile to my car until it was fully registered in Ford's system. The same time it showed up in my ford credit account, I also got the notification of the 22,000 rewards points, and the send to vehicle button showed up for the profile.
 

breeves002

Well-Known Member
First Name
Sam
Joined
Feb 21, 2021
Messages
870
Reaction score
1,704
Location
St. Louis, MO
Vehicles
2021 Mach-E GT PE
Country flag
I could never get my profile to go to the vehicle so I just gave up.

Took me long enough to just get the FordPass app to work.

Try a master reset on sync and start over with everything. Sometimes it's that simple.

I think the biggest issue here is they just were not ready for this launch from a CS standpoint. They didn't have enough knowledge base articles setup for phone support....maybe because they honestly don't know what to do about half of the issues we're seeing. They should have delayed everyone longer in my opinion. It was not ready for launch. Woe's of being on the bleeding edge of technology.
 
OP
OP

Mojuba

Active Member
First Name
Chris
Joined
Jan 28, 2020
Messages
27
Reaction score
29
Location
Huntington Beach
Vehicles
Reserved Mach E First Edition
Country flag
How long ago did you take delivery? I wasn't able to push my profile to my car until it was fully registered in Ford's system. The same time it showed up in my ford credit account, I also got the notification of the 22,000 rewards points, and the send to vehicle button showed up for the profile.
Ahh maybe that's it. How long did it take?

I'll try the reset too, does anyone know how to reset the IOS app so I can rescan a barcode?

Thanks, for everyone's help here.

Chris
 

benk016

Well-Known Member
First Name
Ben
Joined
Nov 12, 2020
Messages
1,535
Reaction score
2,315
Location
Tulsa, Oklahoma
Vehicles
2021 Mustang Mach-E GT
Country flag
Ahh maybe that's it. How long did it take?

I'll try the reset too, does anyone know how to reset the IOS app so I can rescan a barcode?

Thanks, for everyone's help here.

Chris
I picked it up on the 12th, and I had the option to send to vehicle showed up on 2/18.
 

shutterbug

Well-Known Member
First Name
Joseph
Joined
Nov 5, 2020
Messages
924
Reaction score
1,326
Location
AZ
Vehicles
Grabber Blue FE
Country flag
my 4th satisfaction survey with 1s on support
Shouldn't that be 4th dissatisfaction survey? When you call next, speak calmly and tell them that you are extremely unhappy that they keep hanging up on you and helping. Tell them no, you cannot put me on brief hold and that you want them to stay on the line until the next person joins and and to remain until you get someone acknowledging that they can help you.
 

Larry

Well-Known Member
First Name
Larry
Joined
Jan 29, 2021
Messages
250
Reaction score
235
Location
Pennsylvania
Vehicles
Ranger and Mach-E
Occupation
Retired
Country flag
That must be frustrating to say the least - Ford needs to improve the help process for this tech stuff. I am not sure if it helps but have you contacted the dealer? I am not sure we have heard of a hotspot being already active before.
If it is somebody must be paying for it.
 

agoldman

Well-Known Member
Joined
Jan 23, 2020
Messages
2,203
Reaction score
1,858
Location
Maryland
Vehicles
Mach E FE grabber blue - GT cyber orange in prod.
Country flag
I also think that they are entrenched in "dealer Mode". Some habits die hard. I think the service department at the dealer is going to have to be the first line of help for this car for the foreseeable future. basically a forced middleman.
 
Advertisement

 
Advertisement
Top