Electrify America Chargers

rose916

Member
First Name
Rose
Joined
Oct 22, 2021
Threads
3
Messages
10
Reaction score
1
Location
Sacramento
Vehicles
Mach E (CA Route 1) // 1971 Ford Bronco
Occupation
Sales
Country flag
These are free to us it seems
I’ve had my car since Mid October and have charged the car in Sacramento and Los Angeles and these never charge me.

Anyone know if this deal is forever with Ford?
Thanks

 

JGuske23

Well-Known Member
First Name
Justin
Joined
Jul 13, 2021
Threads
1
Messages
89
Reaction score
222
Location
Kalamazoo
Vehicles
Mach E Premium AWD extended range
Occupation
Market manager
Country flag
These are free to us it seems
I’ve had my car since Mid October and have charged the car in Sacramento and Los Angeles and these never charge me.

Anyone know if this deal is forever with Ford?
Thanks
You get 250kw free for buying the mach E, enough for a few full charges
 

bellyer

Well-Known Member
Joined
Jun 25, 2020
Threads
47
Messages
356
Reaction score
548
Location
Chicago
Vehicles
Mach E First Edition
Country flag
Yes, there are the credits that Ford gives, but then there is also a free charging weekend going in right now that EA is running. They seem to do those periodically, often over holiday weekends. Always a nice surprise, like I got yesterday when stopping off at one.
 

Ned

Well-Known Member
First Name
Ned
Joined
Mar 13, 2021
Threads
3
Messages
50
Reaction score
11
Location
Prescott, AZ
Vehicles
waiting for ford
Occupation
retired
Country flag
Yes, there are the credits that Ford gives, but then there is also a free charging weekend going in right now that EA is running. They seem to do those periodically, often over holiday weekends. Always a nice surprise, like I got yesterday when stopping off at one.
I am still using the Kwh that Ford gave me for the purchase of my car. I normally charge at home, but took a trip to CA recently (400 miles). I used the Love station in Quartzite both on the way and on the way home. Electrify America had 4 chargers there, but only 1 would work on both occasions.

On the way back we were programmed to stop in Palm Springs. The planned stop was at an Target that was about 5 miles off the Interstate. There was one that we used on the way down in Indio that was right next to an exit from I10. Has anyone else been taken to a charger that was really out of the way?
 


RickMachE

Well-Known Member
Joined
Jul 1, 2021
Threads
125
Messages
8,439
Reaction score
9,711
Location
SE MI
Vehicles
Mach-E Premium 4X, F-150, Lightning reserved
Country flag
I am still using the Kwh that Ford gave me for the purchase of my car. I normally charge at home, but took a trip to CA recently (400 miles). I used the Love station in Quartzite both on the way and on the way home. Electrify America had 4 chargers there, but only 1 would work on both occasions.

On the way back we were programmed to stop in Palm Springs. The planned stop was at an Target that was about 5 miles off the Interstate. There was one that we used on the way down in Indio that was right next to an exit from I10. Has anyone else been taken to a charger that was really out of the way?
Sure. Got off NY Thruway and drove parallel to highway for miles to outlet mall, then back again. Or 10 miles each way out of the way.

Did you report the bad chargers to EA? And on PlugShare?
 

Illinibird

Well-Known Member
First Name
Mike
Joined
Oct 13, 2020
Threads
40
Messages
1,563
Reaction score
1,439
Location
Frankfort Illinois
Vehicles
2015 Acura MDX Adv; 2016 Titanium Fusion Hybrid
Occupation
retired Endodontist (root canal specialist) and Clinical Assistant Professor
Country flag
It finally happened to me tonight at some EA DC fast chargers. There are four EA fast DC chargers in a parking lot off Route 59 (off I-88) and since our SOC was too low because of cold weather we had to stop and charge. Tried EVSE #1; didn’t recognize the free Ford charging handshake go on for P&C. Tried to start unit with my credit card and it didn’t work either, So I went to #3 and same thing. So I went to #4 and no joy there either. By this time I was freezing and it was dimly lit so it was hard to see on top of the EA EVSE not doing P&C. I called the help number for EA and explained what was going on. After being put on hold for about 5 minutes the agent got back on the phone and said P&C was not working on #1, #3, and #4 chargers (no sh&t Sherlock) and she asked me if I tried #2 as that had P&G working. I said no, that was the only one I skipped so she told me to try it. Bingo! That EVSE worked and I plugged the car in and went to sit inside because by this time I was shivering. It charged us up to 70% which was enough to get home. My wife was furious and said “that’s it! I’m not taking this car in the winter anymore !” We both were upset but the car was charged and we continued home. This was the first time I had trouble when I really needed a charge and I was incredulous that only one out of four units actually worked. I did try to remain calm because I have read others had the same problem on this board. It could have been a disaster because we were down to between 15-20% SOC and we would not have been able to make it without that charge. Just thought I’d add my experience tonight at EA.

 

 
Top