FordPass login broken for anyone else? (iOS)


New Member
First Name
Feb 4, 2023
Reaction score
21 MME Select AWD
Country flag
It logged me out on the one-year anniversary of when I got my MME and set up FordPass; presumably some token expiration or something. I didn't have my password handy and said "Eh, I'll get to it later." This was... Last year at this point. Oops. Anyways, I finally tried last week (I never used the app often anyways) and got the following screen:
Ford Mustang Mach-E FordPass login broken for anyone else? (iOS) 1675736393557

The page is fully loaded--there's a blue loading bar as it loads, and then it disappears when it finishes--but nothing. I figured I might have just hit a maintenance window for the login service, but having checked a dozen times or so since then, it's always been the same thing.

Things I've tried:
  • Copying the URL to a different browser than the embedded Safari window: The page loads and I can log in, but then it just pops me back to FordPass, still not logged in
  • Requesting the desktop version of the site from the embedded Safari window: Same blank page as the screenshot
  • Uninstalling and reinstalling the app: Same behavior
  • Turning on location, which I usually have off: Same behavior
  • Using 4G instead of Wi-Fi in case something about my home network was blocking something: Same behavior
Have been on version 4.23.2 since whenever that came out. Don't know which version I was on when it logged me out.

Anyone else encounter this or know of a fix?