HELP! Touch Screen went BLACK! [SOLVED!]

capt_jak_harkness

Well-Known Member
Joined
Jan 29, 2021
Messages
57
Reaction score
120
Location
IL
Vehicles
Mustang Mach E Premium
Country flag
Updated: SOLVED!

Solution: The Sync4 reset is to hold the volume rocker in the volumne down position and the right arrow key together for 10 seconds (both on the right side of the steering wheel). This resets the 15.5' touchscreen and in my case solved the issue! The screen came right back on and has worked since!



Original post

I have tried searching the forum and I can't find anything, but have any new owners had any issues with the touch screen going completely black and becoming unresponsive?

I have a loaner car for the day and when playing around with various settings the screen froze and went completely black! Nothing I do will get it to turn back on.

The strangest thing though is that when I put the car in reverse the backup cam comes on the screen just like normal. When I go to then switch gears to drive or some other gear it goes back to black.

Has anybody else had this issue? Any Ford engineers on here that can tell me how to reset the screen??

[SOLVED!}
The Sync4 reset is to hold the volume rocker in the volumne down position and the right arrow key together for 10 seconds (both on the right side of the steering wheel). This resets the 15.5' touchscreen and in my case solved the issue! The screen came right back on and has worked since!





Advertisement

 
Last edited by a moderator:
OP

capt_jak_harkness

Well-Known Member
Joined
Jan 29, 2021
Messages
57
Reaction score
120
Location
IL
Vehicles
Mustang Mach E Premium
Country flag
  • Thread starter
  • Thread Starter
  • #3
Not sure if this will help but worth a try. See if you can get the diagnostic mode to display.

https://www.macheforum.com/site/threads/ford-mach-e-bezel-diagnostics-demo.3109/
That was one of my first thoughts too, but unfortunately it didn't do anything.

I even tried to hold other various combinations of the buttons on the steering wheel hoping one of them might reset Sync or the screen or something. But as of yet, nothing has worked.

I'm furiously searching the forums and the internet. I've scoured the online owner's manual (which...I guess is helpful but the more I look through it the more I think it's a waste).

And I don't even own this vehicle!!!!!!!!!!
 

shutterbug

Well-Known Member
First Name
Joseph
Joined
Nov 5, 2020
Messages
342
Reaction score
383
Location
AZ
First Name
Joseph
Vehicles
C-Max Energi
Country flag
The strangest thing though is that when I put the car in reverse the backup cam comes on the screen just like normal. When I go to then switch gears to drive or some other gear it goes back to black.
That probably means that LCD panel is fine, and you have some other issue. Is there a way to reset the car without using the screen?

And I don't even own this vehicle!!!!!!!!!!
I would count that as a win.
 
OP

capt_jak_harkness

Well-Known Member
Joined
Jan 29, 2021
Messages
57
Reaction score
120
Location
IL
Vehicles
Mustang Mach E Premium
Country flag
  • Thread starter
  • Thread Starter
  • #5
That probably means that LCD panel is fine, and you have some other issue. Is there a way to reset the car without using the screen?
Yeah I think (hope...pray) the screen itself is fine. I didn't do anything to cause it to break or freeze.

Also, I haven't found a way to reset anything yet. Turning the car off, locking it, and stepping away for a while seems to shut everything down, so I've done that and I'll go back to it in a minute and see if anything has changed.

I would count that as a win.
Yeah...I just recently placed my Order for this exact spec MME (Premium X AWD), and this experience probably won't make me change my mind (also I likely won't get mine until 2023 anyway), but it's definitely making me think twice about it a little bit.
 

Mopey

Well-Known Member
First Name
John
Joined
Nov 20, 2019
Messages
270
Reaction score
580
Location
Alaska
First Name
John
Vehicles
2016 Mustang CS/Conv/SC
Occupation
Professional Pony Wrangler
Country flag
The display and Sync are on different fuses. Since the display works for the camera, check fuse 17 (Page 279-280 of the manual)
 

Kamuelaflyer

Well-Known Member
First Name
Bill
Joined
Feb 18, 2020
Messages
2,053
Reaction score
3,700
Location
Hawaii
First Name
Bill
Vehicles
Old
Country flag
Check the fuses? Odd as it sounds. The screen fuse is in the body control module fuse box. #4. Worth looking at. And possibly pulling, waiting a bit, then reinstalling.

I think that fuse box is in the cabin of the car.
 

SnBGC

Well-Known Member
First Name
Greg
Joined
Apr 20, 2020
Messages
1,753
Reaction score
2,864
Location
Phoenix
First Name
Greg
Vehicles
Ford Focus Electric, Ford C-Max Energi, 1999 F250 PSD, 2000 F250 PSD, 1968 GTO, 1955 Bel Air
Occupation
Managet
Country flag
That was one of my first thoughts too, but unfortunately it didn't do anything.

I even tried to hold other various combinations of the buttons on the steering wheel hoping one of them might reset Sync or the screen or something. But as of yet, nothing has worked.

I'm furiously searching the forums and the internet. I've scoured the online owner's manual (which...I guess is helpful but the more I look through it the more I think it's a waste).

And I don't even own this vehicle!!!!!!!!!!
Browsing the APIM diagnostics now....
Not finding a way to force reset that module. Will keep reading and see what I can find.
 

SnBGC

Well-Known Member
First Name
Greg
Joined
Apr 20, 2020
Messages
1,753
Reaction score
2,864
Location
Phoenix
First Name
Greg
Vehicles
Ford Focus Electric, Ford C-Max Energi, 1999 F250 PSD, 2000 F250 PSD, 1968 GTO, 1955 Bel Air
Occupation
Managet
Country flag
I have tried searching the forum and I can't find anything, but have any new owners had any issues with the touch screen going completely black and becoming unresponsive?

I have a loaner car for the day and when playing around with various settings the screen froze and went completely black! Nothing I do will get it to turn back on.

The strangest thing though is that when I put the car in reverse the backup cam comes on the screen just like normal. When I go to then switch gears to drive or some other gear it goes back to black.

Has anybody else had this issue? Any Ford engineers on here that can tell me how to reset the screen??
What menu were you in when playing with the settings?
Was the radio on or off. What happens when you touch screen with your finger through the center if the dial knob?
Did you turn off the auto dimming and/or manual brightness control.
 
OP

capt_jak_harkness

Well-Known Member
Joined
Jan 29, 2021
Messages
57
Reaction score
120
Location
IL
Vehicles
Mustang Mach E Premium
Country flag
  • Thread starter
  • Thread Starter
  • #12
What menu were you in when playing with the settings?
Was the radio on or off. What happens when you touch screen with your finger through the center if the dial knob?
Did you turn off the auto dimming and/or manual brightness control.
So, I think I was playing with the heating/air conditioning when it went black.

The radio was on. Nothing happens when I touch the screen anywhere, including the center of the dial knob. The knob is also clicky like a button, so I thought maybe pushing or holding that would do something, and it didn't.
 

SnBGC

Well-Known Member
First Name
Greg
Joined
Apr 20, 2020
Messages
1,753
Reaction score
2,864
Location
Phoenix
First Name
Greg
Vehicles
Ford Focus Electric, Ford C-Max Energi, 1999 F250 PSD, 2000 F250 PSD, 1968 GTO, 1955 Bel Air
Occupation
Managet
Country flag
So, I think I was playing with the heating/air conditioning when it went black.

The radio was on. Nothing happens when I touch the screen anywhere, including the center of the dial knob. The knob is also clicky like a button, so I thought maybe pushing or holding that would do something, and it didn't.
Does the radio still work? Can you get it into AM/FM mode?
Must be tuned to that source in order to enter Bezel Diagnostics (according to the manual....)
 
OP

capt_jak_harkness

Well-Known Member
Joined
Jan 29, 2021
Messages
57
Reaction score
120
Location
IL
Vehicles
Mustang Mach E Premium
Country flag
  • Thread starter
  • Thread Starter
  • #14
Genuine thank you to everyone in this thread helping me problem solve!

Just as an FYI the car seems to have remembered the last settings, so the seat warmer, steering wheel heater, all come on. The last driving mode I was in was Unbridled, and it seems to have changed to Engaged (or some other mode). And the car still operates. I thought maybe driving it around the block would "wake up" the screen but to no avail.

It's parked in my garage now, and it's getting late so I may leave it over night and then troubleshoot with the fuse/battery tomorrow morning. More than likely I'm just going to take it back to the Dealer and hopefully they can fix it and I can take it out again and actually play around with it!!!!
 

JellyBelly

Well-Known Member
First Name
Kris
Joined
Jun 27, 2020
Messages
2,142
Reaction score
1,674
Location
San Diego
First Name
Kris
Vehicles
MME RR FE
Country flag
Not a great way to experience... I wonder the dealer will do something to fix?
 

Advertisement





 


Advertisement
Top